Service Status | xilo Ltd.

All systems are operational.

Shared Hosting and Reseller Hosting
2 days ago —
Fixed

Fixed

2 days ago —

Power to site has been restored and services have been back on line now for over an hour.

Please accept our apologies for the impact to service.

Fixed

2 days ago —

The facilty advised a power outage affecting a number of racks at the location.

Power is restored and services are coming back up.

We will have more information in due course.

2 days ago —

We are seeing issues with a third party provider affecting some services in our London location.

This has been raised with them and we await a response.

Incident UUID 951a16b2-66f0-4524-9ed4-061067cf2cf4